[Debian/Kimsufi] No access to Vesta repository

  • { Mis à jour le 25-05-2019 à 21:46 }
  • { Publié le : 25-04-2019 (Yann.C) }
  • { VestaCP }
Lors de la réinstallation du serveur dédié, j'ai rencontré un problème pour installer VestaCP. Si vous avez un serveur Kimsufi (chez So You Start aussi je crois), il faut savoir qu'OVH trifouille un peu le fichier de version de Debian. Pour pouvoir installer VestaCP il faut éditer etc/issue

Commencez par vous connecter en root dans SSH et entrez

nano /etc/issue

Vous allez vous retrouver devant ceci :

Debian GNU/Linux 9.3 (stretch)
Linux xxxxxxxxx.ip-xx-xxx-xx.eu x.x.xx-xxxx-xxx-ipv6-64 #2 SMP Wed Jan 24 10:27:15 CET 2018 x86_64 GNU/Linux
  Server        : xxxxxx
  IPv4          : xx.xxx.xx.x
  IPv6          : xxxx:xxxx:x:xxxx::x
  Hostname      : xxxxxxxxx.xx-xx-xxx-xx.eu

Commencez par supprimer les espaces présent en haut et à gauche de la ligne "Debian GNU/Linux 9.3 (Stretch)". C'est important de les supprimer sinon l'installateur de Vesta ne prendra pas en compte la distribution et sa version associée.

Justement, en parlant de la version de Debian, éditez cette même ligne afin quelle soit comme ci-dessous

Debian GNU/Linux 9 \n \l

Après vérification, sauvegardez et lancez l'installation de VestaCP